本地搭建的服务器不能裁剪图片

在本地Mint用apache和php搭建了个服务器环境,安装了wordpress。但是上传图片的时候wordpress表示不能对图片进行翻转操作,服务器不支持。之后发现实际上所有改变图片属性的操作都不行。用中文搜索没有发现所以然。换用英文后发现解决方法很简单,好像也有很多人碰到这个问题。只是需要安装一个软件。对Ubuntu来说就是执行下面的安装命令。

sudo apt-get install php5-gd

 

问题解决。

参考网页:http://yuan3y.com/2014/12/there-has-been-an-error-cropping-your-image-solution/

http://itsmetommy.com/2015/12/28/wordpress-there-has-been-an-error-cropping-your-image/

点击量:116

发表评论

电子邮件地址不会被公开。 必填项已用*标注

*